Delayed Webhooks and Notifications
Resolved
Mar 13, 2026 at 4:35pm UTC
All queued webhook events have been processed and delivered. The background worker service has been restarted and connection resilience improvements have been deployed to prevent recurrence.
Affected services
Created
Mar 13, 2026 at 9:14am UTC
Resolved — Between approximately 09:14 UTC and 16:35 UTC on March 13, 2026, webhook deliveries and notification events were delayed. During this window, outbound webhooks and event notifications were queued but not delivered in real time.
What happened: A background processing service lost its connection to an internal dependency and did not automatically recover. This caused event delivery to stall while events continued to be queued.
Impact: Webhook endpoints did not receive events during the affected window. No events were lost — all queued events have since been delivered. API and dashboard access were not affected.
Resolution: The service was restarted and all queued events were processed. We are implementing automatic recovery logic to prevent this type of issue from recurring.
Affected services