Webhook Event Deliveries Disrupted
Resolved
Mar 14, 2026 at 04:35am UTC
All queued webhook events have been processed and delivered. The background worker service has been restored and connection resilience improvements have been deployed to prevent recurrence.
Affected services
Updated
Mar 12, 2026 at 02:59pm UTC
All endpoint configurations corrected. Missed events replayed and successfully delivered.
Affected services
Created
Mar 08, 2026 at 09:32pm UTC
Resolved — Following an infrastructure migration on March 8, webhook event deliveries were disrupted. Events were created and recorded successfully, but were not delivered to partner endpoints between March 8 and March 12.
What happened: A planned infrastructure migration caused the webhook delivery service to start in a clean state. Endpoint routing configuration from the previous environment was not fully carried over, preventing the service from matching events to endpoints.
Impact: No webhook events were delivered during this window. No events were lost — all affected events were identified, replayed, and successfully delivered on March 12.
Resolution: All endpoint configurations were corrected, missed events were replayed, and a fix was deployed to ensure endpoint data is properly persisted going forward.
Affected services